E31 looses "compass" direction, shifting the map and failing the cleaning

Dear all,

I was loving the product, but after the first cleanings it started more and more loosing its compass direction , making the map to rotate and failing the complete house cleaning. You can clearly see it through the map that at the cycle beginning is straight and then starts to rotate, falling in the thinking that the track is complete, instead there are lot of zones still undone.

Other than that, a piece of the right part of the map makes always disappear as new map on the left creates (it's not out of zoom, it's completely lost, at least from the app view), making even harder to understand if a zone has been done or not.

I tried changing direct WiFi with AP ( thinking of a problem of connection), cleaning sensors, cleaning wheels, removed all the 'movable' carpets to avoid dragging and reset to factory app and robot, what else to do? I hope it's not a defect, because my 110 square m house is always only partially completed when cleaning, because of this problem. I attach some screenshots of the map where you can easily understand where it rotates (no one touches the robot during whole operation). I have other pics if needed, rotations seems to be random. Thanks in advance


Comments

  • I also seem to be having a similar problem. The first few cleaning were great and the vacuum went through the whole house. But then afterwards it started to only clean the living room and hallway. I say “house” but I live in an apartment so it’s not a huge place. The vacuum has plenty of battery and just clans the same space over and over. I’ve tried resetting the vacuum on the app but I think it made things worse.

Sign In or Register to comment.